《实力团队》诚招传奇游戏技术 检测技术 登陆器技术 接手游、端游工作室项目,另邀请工作室 qq:8427499 诚邀端游,页游,手游作者合作。联系QQ:4700828
《实力团队》诚招传奇游戏技术 检测技术 登陆器技术 全国PPTP L2TP单地区ADSL 超级包机VPN QQ2413588810   【天庭团队】诚招实力作者和出卡代理Q1916501075
《实力团队》诚招传奇游戏技术 检测技术 登陆器技术 ██████不知道为什么,突然想打个广告██████ ██████不知道为什么,突然想打个广告██████
《实力团队》诚招传奇游戏技术 检测技术 登陆器技术 全国PPTP L2TP单地区 混播 超级包机VPN QQ770762897 昌明科技 混拨 动态ip 动态vps 挂机宝 点击进入官网
诚邀端游,页游,手游作者合作共赢。联系QQ:25866957 诚邀端游页游手游作者技术总代合作。联系QQ:67880293 工作室招实力写手月薪15K起加分层,联系QQ:四六一九五二
500双路E5 48G倒闭边缘,出租 合作 都可以QQ809020754 诚邀各大堡垒总代合作。联系QQ188892104 收系统变速器源码(驱动源码)qq944479699
长期收DXF读写驱动,价格好谈,另招出卡大牛Q:1051201352 赞助广告位(点击查看报价) 赞助广告位(点击查看报价)
【GK实力团队】(天使)项目 诚邀实力代理加入 日出卡上百来 【GK实力团队】(天使)项目 诚邀实力代理加入 日出卡上百来 【GK实力团队】(天使)项目 诚邀实力代理加入 日出卡上百来
  • 2170阅读
  • 11回复

完美喊话call 怎么发送装备到聊天窗口? [复制链接]

上一主题 下一主题
离线ai126891
 

发帖
183
金钱
179
威望
125
贡献值
50
社区警告
0
诚信值
150
热心值
0
协调
0
只看楼主 倒序阅读 0楼 发表于: 2015-09-10
004EA5F7   > \8B4C24 3C     MOV ECX,DWORD PTR SS:[ESP+3C]            ;  堆栈 SS:[0012DF58]=0AE3B668 lame/B&nc  
004EA5FB   .  8B5424 18     MOV EDX,DWORD PTR SS:[ESP+18]            ;  0012DF1C ]rcF/uQJ<n  
004EA5FF   .  51            PUSH ECX                                 ;  ECX=00000000 ECX=2232D170 h}b:-a  
004EA600   .  57            PUSH EDI                                 ;  EDI=05D5434C t=_^$M,yr  
004EA601   .  52            PUSH EDX                                 ;  喊话频道0普通1世界2组队 `:/'")+@v  
004EA602   .  8BCD          MOV ECX,EBP                              ;  EBP=01A001F0 ^xo<$ zn  
004EA604   .  E8 473F1500   CALL elementc.0063E550 GAGS-G#  
!^J;S%MB:K  
push ecx值为0 可以在游戏喊话成功,发送装备到聊天  ecx值会变
 
外挂学习,完美国际。。。别的暂停
离线ai126891

发帖
183
金钱
179
威望
125
贡献值
50
社区警告
0
诚信值
150
热心值
0
协调
0
只看该作者 1楼 发表于: 2015-09-10
没人看了么?
温馨提示:为确保交易资金安全,强烈建议您选择广海社区中介服务,私下交易造成损失的,本站概不负责,详情点击查看
 
外挂学习,完美国际。。。别的暂停
离线Hkrak

发帖
291
金钱
1253
威望
131
贡献值
10
社区警告
0
诚信值
0
热心值
0
协调
0
只看该作者 2楼 发表于: 2015-09-11
你跟一下3c的基址不就ok嗎
站点帮助:验证问题答案举例,如验证问题:3+5=?,请输入中文答案:八
 
离线ai126891

发帖
183
金钱
179
威望
125
贡献值
50
社区警告
0
诚信值
150
热心值
0
协调
0
只看该作者 3楼 发表于: 2015-09-11
回 Hkrak 的帖子
Hkrak:你跟一下3c的基址不就ok嗎 (2015-09-11 00:04)  ]`kmjn  
ch0{ +g&  
。。。跟不到啊
外挂学习,完美国际。。。别的暂停
离线ai126891

发帖
183
金钱
179
威望
125
贡献值
50
社区警告
0
诚信值
150
热心值
0
协调
0
只看该作者 4楼 发表于: 2015-09-11
.版本 2 <C(2(3  
L;<]wKs  
.子程序 发送玩家名称到服务器 C ^'}{K  
.参数 玩家名称, 文本型 *}=W wG  
.局部变量 名称, 字节集 nMqU6X>P!  
.局部变量 角色名地址, 整数型 wu3ZSLY  
.局部变量 esi, 整数型 w}?\Q,  
*{Vyt5  
名称 = Ansi转Unicode (玩家名称) $@X,J2&  
角色名地址 = 分配内存地址 (取字节集长度_ (名称)) ! >V 1zk  
内存写字节集 (角色名地址, 名称) Y|bGd_j  
esi = 读游戏内存 (基址, 一级偏移, 24, 8, 140, 8, 456, 8, 16) TDFv\y}yc  
置代码 ({  }) 8vCHH&`  
push_常数 (3) i "xq SLf=  
mov_eax_常数 (角色名地址) C" {j0X`  
push_eax () ) PtaX|U  
mov_ecx_常数 (esi) f/xBR"'  
mov_ebx_常数 (取IDcall1) 7u;B[qH  
call_ebx () U]d+iz??b  
mov_ecx_eax () $%<gp@Gz  
mov_ebx_常数 (取IDcall2) "D+QT+sD  
call_ebx () CwAl-o  
ret () Zn/1uWO  
调用函数 (_取代码 ()) 1FuChd  
内存释放 (角色名地址) q?6Zu:':  
RZ -w,~  
还会有人看么? >Kx l+F  
来个call  像服务器发送一个玩家名称,再在本地可取玩家的ID,在线不在线都成
外挂学习,完美国际。。。别的暂停
离线c08434

发帖
26
金钱
484
威望
526
贡献值
0
社区警告
0
诚信值
0
热心值
0
协调
0
只看该作者 5楼 发表于: 2015-09-11
回 ai126891 的帖子
ai126891:.版本 2
.子程序 发送玩家名称到服务器 YH_mWN\Wu  
.参数 玩家名称, 文本型 yr4j  
.局部变量 名称, 字节集 4r'QP .h  
....... (2015-09-11 12:02)  Y|'0bujr  
Z%h _g-C  
不在线能取到??
离线叶落丶

发帖
30
金钱
486
威望
540
贡献值
0
社区警告
0
诚信值
0
热心值
0
协调
0
只看该作者 6楼 发表于: 2015-09-12
push ecx    ecx=0是为纯文字喊话,发送装备属性时,为装备指针 SLNq%7apx  
$)~:H-  
加智辅交流群:189186126(完美世界交流群)
离线ai126891

发帖
183
金钱
179
威望
125
贡献值
50
社区警告
0
诚信值
150
热心值
0
协调
0
只看该作者 7楼 发表于: 2015-09-12
回 c08434 的帖子
c08434:[表情] 不在线能取到?? (2015-09-11 17:48)  z ''-AH,  
vs~lyM/  
可以取到,在线不在线不影响
外挂学习,完美国际。。。别的暂停
离线ai126891

发帖
183
金钱
179
威望
125
贡献值
50
社区警告
0
诚信值
150
热心值
0
协调
0
只看该作者 8楼 发表于: 2015-09-12
回 叶落丶 的帖子
叶落丶:push ecx    ecx=0是为纯文字喊话,发送装备属性时,为装备指针
加智辅交流群:189186126(完美世界交流群) (2015-09-12 03:49)  iT2B'QI=<  
t.xxSU5~%  
push物品指针 还是不行?
外挂学习,完美国际。。。别的暂停
离线ai126891

发帖
183
金钱
179
威望
125
贡献值
50
社区警告
0
诚信值
150
热心值
0
协调
0
只看该作者 9楼 发表于: 2015-09-13
解决, 3' ~gvi I  
push ecx常量 FuUD 61JHY  
ecx+8//0背包1身上 j:}J}P  
ecx+c//位置
外挂学习,完美国际。。。别的暂停